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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

l Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

l Bold type is used for the following:
o Keyboard entries that should be typed in their entirety exactly as shown. For
example, “copy file1” means you must type the word copy, then type a space, and
then type file1.

o On-screen prompts and messages, names of options and text boxes, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click HFSS > Excitations > Assign >Wave Port.”

o Labeled keys on the computer keyboard. For example, “Press Enter” means to
press the key labeled Enter.

l Italic type is used for the following:
o Emphasis.
o The titles of publications.
o Keyboard entries when a name or a variable must be typed in place of the words in
italics. For example, “copy filename” means you must type the word copy, then
type a space, and then type the name of the file.

l The plus sign (+) is used between keyboard keys to indicate that you should press the
keys at the same time. For example, “Press Shift+F1” means to press the Shift key and,
while holding it down, press the F1 key also. You should always depress the modifier key
or keys first (for example, Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and
then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

l The Ribbon occupies the rectangular area at the top of the application window and con-
tains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Draw > Line"

This instruction means that you should click the Line command on the Draw ribbon tab.
An image of the command icon, or a partial view of the ribbon, is often included with the
instruction.

l Themenu bar (located above the ribbon) is a group of the main commands of an applic-
ation arranged by category such File, Edit, View, Project, etc. An example of a typical user
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interaction is as follows:

"On the Filemenu, click theOpen Examples command" means you can click the File
menu and then clickOpen Examples to launch the dialog box.

l Another alternative is to use the shortcut menu that appears when you click the right-
mouse button. An example of a typical user interaction is as follows:

“Right-click and select Assign Excitation> Wave Port” means when you click the right-
mouse button with an object face selected, you can execute the excitation commands
from the shortcut menu (and the corresponding sub-menus).

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached, including software files as applicable. This allows
more rapid and effective debugging.

Help Menu

To access help from the Help menu, click Help and select from the menu:

l [product name] Help - opens the contents of the help. This help includes the help for the
product and itsGetting Started Guides.

l [product name] Scripting Help - opens the contents of the Scripting Guide.
l [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1. The help specific to the active product (design
type) opens.

You can press F1 while the cursor is pointing at a menu command or while a particular dialog
box or dialog box tab is open. In this case, the help page associated with the command or open
dialog box is displayed automatically.
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1 - Introduction
This document is intended as supplementary material to Icepak for beginners and advanced
users. It demonstrates how to model a cold plate.

In this tutorial you will learn how to:

l Use a mesh region and mesh operation to mesh complicated model setups
l Use multiple fluids in a single model.
l Account for external natural convection and internal forced convection.
l Create mesh regions to reduce the overall mesh count.
l Specify per-object meshing parameters.

This chapter contains the following topic:

l "Sample Project - The Cold Plate" below

Sample Project - The Cold Plate
The model consists of a cold-plate, where the cold-plate fluid is transporting a significant fraction
of the heat from two plates mounted on either side of it. The natural convection in the external air
is also instrumental to heat transfer in this case. The objective of this exercise is to illustrate the
use of two different fluids

Figure 1-1: Cold Plate
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2 - Open the Project and Review the
Model

After launching the Ansys Electronics Desktop, create a project, insert an Icepak design, and
build the model.

Launch the Ansys Electronics Desktop
A shortcut of the Ansys Electronics Desktop application appears on your desktop once the applic-
ation is installed.

Set 3D UI Options
Ensure that the new view orientation scheme introduced in release 2024 R1 is not being used,
since the instructions and images in this guide are based on the legacy orientation scheme.

1. From the menu bar, click View >Options.

The 3D UI Options dialog box appears.

2. Ensure that Enable Legacy View Orientation is enabled:

Getting Started with Icepak®: Cold Plate Model
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3. ClickOK.

Open the Project

1. On the Desktop ribbon tab, click Open Examples.
2. Double-click the Icepak folder.
3. Select the file Cold_Plate.aedt and clickOpen.
4. The model is displayed in the 3D Modeler window.

Note: You can hide the grid by selecting View >Grid Settings and then selecting Hide in
theGrid Spacing dialog box. Also, from the View > Coordinate Systemsmenu, you can
hide the large coordinate triad and display a smaller coordinate triad in the bottom of the
3D Modeler window.

Open the Project and Review the Model 2-2
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Figure 2-1: Cold Plate model in the 3D Modeler window

5. From the Filemenu, select Save As, and save the project in the desired working dir-
ectory.

Review the Model
The model includes two heated plates, cooled by water circulating inside the cold-plate cavity,
as well as by air driven by natural convection externally. Mesh regions will be employed to
reduce the overall mesh count in the domain.

Open the Project and Review the Model 2-3
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3 - Assign Boundary Conditions
Assign Openings
Assign Cabinet Openings
The openings at the cabinet boundary define external air natural convection.

1. Press F to enter face selection mode.
2. In the 3D Modeler window, select the +X face of the Region.
3. Right-click and select Assign Thermal > Opening > Free.
4. In theOpening Thermal Model dialog box, retain the default settings and clickOK.
5. In the 3D Modeler window, select the -X face of the Region.
6. Right-click and select Assign Thermal > Opening > Free.
7. In theOpening Thermal Model dialog box, retain the default settings and clickOK.

Assign Liquid Inflow and Outflow Openings
The circular openings on the -Y side of the assembly define the inflow and outflow of the liquid
cold plate.

1. In the History tree, expandModel > assembly_1 > Sheets.
2. Right-click opening_1 and select Assign Thermal > Opening > Free.
3. In theOpening Thermal Model dialog box, enter Outlet for the Name, retain the default

thermal settings, and clickOK.
4. In the History tree, right-click opening_2 and select Assign Thermal > Opening > Free.
5. In theOpening Thermal Model dialog box, define the following parameters:

l Name: Inlet
l Flow Specification Inlet Type: Velocity
l Y Velocity: 0.2 m_per_sec

6. Click OK.
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Assign Plates
1. PressO to enter object selection mode.
2. Hover the cursor above plate_2 as shown below and then click to select the geometry.

3. Right-click and select Assign Thermal > Block.
4. In the Block Thermal Model dialog box, enter 200 W for the Total Power.
5. ClickOK.
6. In the History tree, expandModel > assembly_1 > Solids > Al-Extruded.
7. Right-click plate_1 and select Assign Thermal > Block.
8. In the Block Thermal Model dialog box, enter 200 W for the Total Power.
9. ClickOK.

Assign Boundary Conditions 3-2
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4 - Assign a Mesh Region and Operation
Assign a Mesh Region to the Non-Model Box

1. In the History tree, expandModel > Assembly_1 Solids > Non-Model.
2. Right-click assembly_1_mr1 and select Assign Mesh Region.
3. In the SubRegion dialog box, clickOK to close the dialog box without adding padding.
4. In theMesh Region dialog box, enter assembly for the Name.
5. On theMesh Region Advanced tab, select User Specified.
6. Define theMaximum Element Size:

l X: 0.02 meter
l Y: 0.015 meter
l Z: 0.01 meter

7. DisableMulti-level meshing.

Assign a Mesh Operation to the Cold Plate
The mesh needs to be refined for the inner prismatic fluid block (block_2). Assign a mesh oper-
ation and use local mesh parameters to refine the mesh.

Note: The X, Y, and Z counts are also known as element counts, the number of divi-
sions into which an edge is subdivided. In other words, an element count is the number
of elements that lie along the edge.

1. In the History tree, expandModel > assembly_1 > Solids > Water(@280K).
2. Right-click block_2 and select Assign Mesh Operation.
3. In theMesh Operation dialog box, select Local mesh parameters.
4. On the Local Mesh Parameter tab, define the following parameters:

l X count: 30
l Y count: 16
l Z count: 10

5. ClickOK.

Getting Started with Icepak®: Cold Plate Model
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5 - Generate and Display the Mesh
After creating the mesh region and operation, generate and display the mesh.

1. In the Project Manager, right-clickMesh and selectGenerate Mesh. TheMesh Visu-
alization dialog box automatically appears after the meshing process completes.

2. In theMesh Visualization dialog box underMesh display on, enable Show and select
Cut plane.

3. On theModel ribbon, select Top from theOrient drop-down list.

Getting Started with Icepak®: Cold Plate Model

Generate and Display Mesh 5-1

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



PDF layout 5-2

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.

Getting Started with Icepak®: Cold Plate Model



6 - Create Monitor Points
Before running the simulation, create thermal and flow monitors for the outlet opening, a hot
plate, and the cold plate.

Create Thermal Monitors
1. In the History tree, expandModel > assembly_1 > Solids > Al-Extruded.
2. Right-click plate_2 and select Assign Monitor > Point.
3. In theMonitor Setup dialog box, enter a Name of Hot Plate Temp.
4. Expand Thermal and select Temperature.
5. Click OK.
6. In the History tree, expandModel > Water(280K).
7. Right-click block_2 and select Assign Monitor > Point.
8. In theMonitor Setup dialog box, enter a Name of Cold Plate Temp.
9. Expand Thermal and select Temperature.
10. ClickOK.

Create a Flow Monitor
1. In the History tree, expandModel > assembly_1 > Sheets >Opening.
2. Right-click opening_1 and select Assign Monitor > Point.
3. In theMonitor Setup dialog box, enterOutlet Speed for the Name.
4. Expand Flow and select Speed.
5. ClickOK.

Getting Started with Icepak®: Cold Plate Model
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7 - Define the Simulation Settings and
Run the Analysis

Define the Design Settings
1. From the Icepakmenu, select Design Settings.
2. On the Icepak Design Settings dialog boxGravity tab, selectGlobal::X and Negative to

define the force of gravity in the negative Y direction based on the Global coordinate sys-
tem.

3. ClickOK.

Add a Solution Setup
1. In the Project Manager, right-click Analysis and select Add Solution Setup.
2. On the Icepak Solve Setup dialog boxGeneral tab, change theMaximum Number of

Iterations to 300.
3. Under Problem Types, retain the selections to solve for both Temperature and Flow.
4. Under Flow Regime, select Turbulent and clickOptions. In the Turbulent Flow Model

dialog box, select Two Equation selection and clickOK.
5. Under Radiation Model, retain theOff selection to ignore heat transfer due to radiation.
6. Select Include Gravity.

Getting Started with Icepak®: Cold Plate Model
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7. ClickOK
8. From the Filemenu, click Save.

Run the Simulation
1. In the Project Manager, expand Analysis.
2. Right-click Setup1 and select Analyze.

Note:When the simulation is complete, a message is displayed in theMes-
sages window stating "Normal completion of simulation on server."

Add a Solution Setup and Run the Simulation 7-2
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3. Right-click Setup1 and select Residuals to monitor the simulation residuals.

4. Click the Thermal Monitor tab to review the temperature monitor on the hot and cold
plates.

Add a Solution Setup and Run the Simulation 7-3
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5. Click the Flow Monitor tab to review the speed monitor on the outlet opening.

Add a Solution Setup and Run the Simulation 7-4
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6. Click Close

Add a Solution Setup and Run the Simulation 7-5
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8 - Post-process the Results
The Ansys Electronics Desktop provides a number of ways to view and examine the solution res-
ults, including:

l Object face views
l Plane cut views
l Fields summary report

Create Object Field Overlays
Plot Temperature on the Heat Sink
1. In the History tree, expandModel > assembly_1 > Solids.
2. Right-click Al-Extruded and select Select All.
3. Right-click in the 3D Modeler window and select Plot Fields > Temperature > Tem-

perature.
4. In the Create Field Plot dialog box, enable Specify Name and enter assembly.
5. Retain the Temperature selection forQuantity.
6. Enable Plot on surface only.
7. ClickOK.

Note: The field overlay appears in the Project Manager under Field Overlays
> Temperature. You can hide the overlay by right-clicking on it and selecting

Getting Started with Icepak®: Cold Plate Model
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Plot visibility.

Create Plane Cut Field Overlays
Create a Plane
1. From the Drawmenu, select Plane.
2. In the 3D Modeler window, click twice to draw a plane.
3. In the History tree, expand Planes and select Plane1.
4. In the Properties window, edit the following properties:

l Name: cut-plane
l Root point: 0.2 ,0.15 ,0.1 meter
l Normal: 0 ,0 ,1 meter

Plot Speed
1. In the History tree, select cut-plane.
2. Right-click in the 3D Modeler window and select Plot Fields > Velocity > Speed.
3. In the Create Field Plot dialog box, enable Specify Name and enter cut-speed.

Post-process the Results 8-2
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4. Retain the Speed selection forQuantity and clickOK.
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9 - Summary
In this tutorial, you modeled a cold-plate that included two heat plates cooled by water circulating
inside the cold-plate cavity as well as air driven by natural convection externally. This exercise
has also demonstrated how to model multiple fluids in a single model, account for external nat-
ural convection and internal forced convection, create a mesh region to reduce the overall mesh
count, and specify per-object local meshing parameters.

Getting Started with Icepak®: Cold Plate Model
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